MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000121Kolibri OS (trunk)[All Projects] Applicationspublic2017-11-18 22:002019-05-13 16:22
Reporterdunkaist 
Assigned Todunkaist 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platformx86_64OSGNU/LinuxOS Versionup to date
Product VersionSVN build / автосборка SVN 
Target VersionSVN build / автосборка SVNFixed in VersionSVN build / автосборка SVN 
Summary0000121: kpack and kerpack for Linux don't build
Description[ivan@ddesk kerpack_linux]$ make -B
fasm kpack64.asm kpack64.o
flat assembler version 1.72 (16384 kilobytes memory)
3 passes, 6192 bytes.
gcc -c -O3 -o LZMAEncoder-kpack.o lzma_c/LZMAEncoder.c
lzma_c/LZMAEncoder.c: In function ‘CEncoder_Create’:
lzma_c/LZMAEncoder.c:304:6: warning: cast from pointer to integer of different size [-Wpointer-to-int-cast]
  a = (unsigned)workpos & 3;
      ^
lzma_c/LZMAEncoder.c: At top level:
lzma_c/LZMAEncoder.c:1032:1: warning: ‘stdcall’ attribute ignored [-Wattributes]
 {
 ^
lzma_c/LZMAEncoder.c:1042:1: warning: ‘stdcall’ attribute ignored [-Wattributes]
 {
 ^
gcc -c -O3 -o MatchFinder.o lzma_c/MatchFinder.c
gcc -c -O3 -o RangeCoder.o lzma_c/RangeCoder.c
gcc -nostartfiles -o kpack kpack64.o LZMAEncoder-kpack.o MatchFinder.o RangeCoder.o
fasm kerpack64.asm kerpack64.o
flat assembler version 1.72 (16384 kilobytes memory)
3 passes, 5368 bytes.
gcc -c -DFOR_KERPACK -O3 -o LZMAEncoder-kerpack.o lzma_c/LZMAEncoder.c
lzma_c/LZMAEncoder.c: In function ‘CEncoder_Create’:
lzma_c/LZMAEncoder.c:304:6: warning: cast from pointer to integer of different size [-Wpointer-to-int-cast]
  a = (unsigned)workpos & 3;
      ^
lzma_c/LZMAEncoder.c: At top level:
lzma_c/LZMAEncoder.c:1032:1: warning: ‘stdcall’ attribute ignored [-Wattributes]
 {
 ^
lzma_c/LZMAEncoder.c:1042:1: warning: ‘stdcall’ attribute ignored [-Wattributes]
 {
 ^
gcc -nostartfiles -o kerpack kerpack64.o LZMAEncoder-kerpack.o MatchFinder.o RangeCoder.o

[ivan@ddesk kerpack_linux]$ ./kpack
./kpack: Symbol `write' causes overflow in R_X86_64_PC32 relocation
./kpack: Symbol `exit' causes overflow in R_X86_64_PC32 relocation
./kpack: Symbol `exit' causes overflow in R_X86_64_PC32 relocation
./kpack: Symbol `fopen' causes overflow in R_X86_64_PC32 relocation
./kpack: Symbol `fopen' causes overflow in R_X86_64_PC32 relocation
./kpack: Symbol `malloc' causes overflow in R_X86_64_PC32 relocation
./kpack: Symbol `malloc' causes overflow in R_X86_64_PC32 relocation
./kpack: Symbol `malloc' causes overflow in R_X86_64_PC32 relocation
./kpack: Symbol `malloc' causes overflow in R_X86_64_PC32 relocation
./kpack: Symbol `malloc' causes overflow in R_X86_64_PC32 relocation
./kpack: Symbol `fread' causes overflow in R_X86_64_PC32 relocation
./kpack: Symbol `fclose' causes overflow in R_X86_64_PC32 relocation
./kpack: Symbol `fclose' causes overflow in R_X86_64_PC32 relocation
./kpack: Symbol `free' causes overflow in R_X86_64_PC32 relocation
./kpack: Symbol `free' causes overflow in R_X86_64_PC32 relocation
./kpack: Symbol `free' causes overflow in R_X86_64_PC32 relocation
./kpack: Symbol `fwrite' causes overflow in R_X86_64_PC32 relocation
./kpack: Symbol `utimes' causes overflow in R_X86_64_PC32 relocation
Segmentation fault (core dumped)

[ivan@ddesk kerpack_linux]$ ./kerpack
./kerpack: Symbol `write' causes overflow in R_X86_64_PC32 relocation
./kerpack: Symbol `exit' causes overflow in R_X86_64_PC32 relocation
./kerpack: Symbol `exit' causes overflow in R_X86_64_PC32 relocation
./kerpack: Symbol `fopen' causes overflow in R_X86_64_PC32 relocation
./kerpack: Symbol `fopen' causes overflow in R_X86_64_PC32 relocation
./kerpack: Symbol `malloc' causes overflow in R_X86_64_PC32 relocation
./kerpack: Symbol `malloc' causes overflow in R_X86_64_PC32 relocation
./kerpack: Symbol `malloc' causes overflow in R_X86_64_PC32 relocation
./kerpack: Symbol `malloc' causes overflow in R_X86_64_PC32 relocation
./kerpack: Symbol `fread' causes overflow in R_X86_64_PC32 relocation
./kerpack: Symbol `fclose' causes overflow in R_X86_64_PC32 relocation
./kerpack: Symbol `fclose' causes overflow in R_X86_64_PC32 relocation
./kerpack: Symbol `free' causes overflow in R_X86_64_PC32 relocation
./kerpack: Symbol `free' causes overflow in R_X86_64_PC32 relocation
./kerpack: Symbol `fwrite' causes overflow in R_X86_64_PC32 relocation
Segmentation fault (core dumped)
Steps To Reproduce$ cd /programs/other/kpack/kerpack_linux
$ make
Additional InformationI suspect this caused by updated toolchain, since kerpack source hasn't been changed for a long time. Too late to investigate today.

GCC 7.2.0 / Binutils 2.29.1
TagsNo tags attached.
SVN revision / ревизия SVN7112
Type of distribution / Тип дистрибутиваany / любой
Attached Files

- Relationships

-  Notes
(0000202)
dunkaist (administrator)
2019-02-05 00:35

Fixed with -no-pie, r7582.

- Issue History
Date Modified Username Field Change
2017-11-18 22:00 dunkaist New Issue
2019-02-05 00:35 dunkaist Note Added: 0000202
2019-02-05 00:35 dunkaist Assigned To => dunkaist
2019-02-05 00:35 dunkaist Status new => resolved
2019-02-05 00:35 dunkaist Resolution open => fixed
2019-02-05 00:35 dunkaist Fixed in Version => SVN build / автосборка SVN
2019-05-13 16:22 dunkaist Status resolved => closed


Copyright © 2000 - 2021 MantisBT Team
Powered by Mantis Bugtracker